Quicken 2014 - New Features
Click here to view what's new for 2014

.NET 4.0 needed for Installation
Quicken 2014 requires the .NET 4.0 Framework

Error OL221A - Unable to verify Financial institute
Steps to refresh your Financial Information

Identify Fraudulent Websites and Emails
Beware of scams and fake websites

Read the Quicken Sunset & Discontinuation Policy
Find out which products are no longer supported

Product updates
Download the latest updates

Manuals
Download manuals and guides

Sunset and Discontinuation Policy
Quicken 2009 users affected