NETFILE Error Codes
List of most common NETFILE errors

TurboTax will not Install
Click here for an updated Backup Installer

NETFILE Error – Entries in Financial Statement require correction
Click here for a solution

NETFILE Error code 90308
Click here for more details.

TurboTax 2013 requires .NET Framework
You might be asked to install version 4.0. Please allow

Video Guides
TurboTax Canada answers your questions 

Product updates
Manually download updates to TurboTax

NETFILE demo
Step by Step guide and video